ClubEnsayos.com - Ensayos de Calidad, Tareas y Monografias
Buscar

Pseudocódigo y diagrama de flujo


Enviado por   •  6 de Marzo de 2019  •  Síntesis  •  4.039 Palabras (17 Páginas)  •  8 Visitas

Página 1 de 17

Universidad Mariano Gálvez de Guatemala

Centro Universitario de  Huehuetenango

Curso: Lógica de Sistemas

Carrera: Ingeniería en Sistemas de Información y Ciencias de la Computación

Catedrático: Ing. José Wilfredo Alarcón Elias

[pic 1]

Tema: Pseudocódigos y Diagramas de Flujo

Mélany Menara Gutiérrez Gramajo

Carné: 0904-17-8968

28 de Febrero de 2017

[pic 2]

Indique si un número ingresado es primo o                          compuesto.

Pseudocódigo

Programa: primo_compuesto

Modulo: main

Variables:

        band: booleano

        num: entero

        multi: real

Inicio

                Asignar a multi <- 2;

                Asignar a band <- verdadero;

                Escribir 'Ingresar un número';

                Leer num;

                Mientras band=verdadero Y multi

                        Si num MOD multi=0 Entonces

                                band <- Falso;

                        Sino

                                multi <- multi+1;

                        FinSi

                FinMientras

                Si band=verdadero Entonces

                        Escribir 'El número es primo';

                Sino

                        Escribir 'El número es compuesto';

                FinSi

                Fin

Diagrama de Flujo

[pic 3]

[pic 4]

Mostrar la suma de los 25 primeros números entre 1 y 1000 que sean divisibles por uno dado.

Pseudocódigo

Programa: suma_divisibles

Modulo: main

Variables:

divisor: entero

suma, contador, numero: reales

        

Inicio

        Asignar a suma   <- 0;

        Asignar a contador  <-  0;

        Escribir "Introducir número: ";

        Leer divisor;

        Si divisor>0 entonces

        Para numero <- 1 hasta 1000 Hacer

                Si numero % divisor = 0 Entonces

                        suma <-  suma + numero;

                        contador <- contador + 1;

                        Escribir numero;

                FinSi

                Si contador = 25 Entonces

                        Interrumpir;

                        Escribir "La suma es ", suma;        

                FinSi

        FinPara

        Sino

                Regresar a incio;

        Fin si

Fin

Diagrama de Flujo

[pic 5]

[pic 6]

El usuario debe de ingresar un número del 1 y 100, el sistema debe de mostrar el rango de números desde el 0 hasta el número ingresado, y por último el sistema debe de mostrar la suma de estos valores mostrados. Por ejemplo si se ingresa el 5, debe de mostrar 1,2,3,4,5 y la suma seria: 15.

Pseudocódigo

Programa: rango_suma

Modulo: main

Variables:

        suma, num, a: enteros

Inicio

        Asignar a suma<-0;

        Escribir "Ingrese un número del 1 al 100";

        Leer num;

        Si num>0 y num<101 entonces

                Para a<-0 hasta num con paso 1 Hacer

                        Escribir a;

                        suma <-suma+a;

                FinPara

                Escribir "TOTAL: ", suma;

        Sino

                Regresar a Inicio;

        FinSi

Fin

Diagrama de Flujo

[pic 7]

[pic 8]

Una persona arma 45 mesas en 9 horas si al día siguiente tiene que armar 75 mesas, ¿Cuántas horas de trabajo debe realizar?

Pseudocódigo

Programa: calculo_hora

Modulo: main

Variables:

        a,b: reales

Inicio

Escribir "Una persona arma 45 mesas en 9 horas si al día siguiente tiene que armar 75 mesas, ¿Cuántas horas de trabajo debe realizar?";

        a<-(45/9);

        b<-(75/a);

        Escribir "Tiene que realizar ", b, " horas de trabajo.";

Fin

Diagrama de Flujo

[pic 9]

[pic 10]

El sistema debe de solicitar al usuario un año específico, luego el sistema debe de determinar si es bisiesto o no.

Pseudocódigo

Programa: bisiesto

Modulo: main

Variables:

        a: entero

Inicio

        Escribir "Ingrese año:";

...

Descargar como (para miembros actualizados)  txt (12.5 Kb)   pdf (633.4 Kb)   docx (375.2 Kb)  
Leer 16 páginas más »
Disponible sólo en Clubensayos.com