ClubEnsayos.com - Ensayos de Calidad, Tareas y Monografias
Buscar

Arreglos y Registros 06 ejercicio


Enviado por   •  11 de Febrero de 2019  •  Trabajos  •  1.361 Palabras (6 Páginas)  •  7 Visitas

Página 1 de 6

Algoritmo vinos_pseudo

        Escribir 'ingrese los años'

        Leer a

        totalVino

        vinos

FinAlgoritmo

Funcion vinos

        Definir i,i2 Como Entero

        Dimension v[(tv)+(a)]

        Para i<-0 Hasta tv Hacer

                Si (i<-1) Entonces

                        Escribir 'vinoA:'

                FinSi

                Si (i<-2) Entonces

                        Escribir 'vinoB:'

                FinSi

                Si (i<-3) Entonces

                        Escribir 'vinoC:'

                FinSi

                Si (i<-4) Entonces

                        Escribir 'vinoD:'

                FinSi

                Si (i<-5) Entonces

                        Escribir 'vinoE:'

                FinSi

                Para i2<-0 Hasta anios Hacer

                        Escribir 'los años:'

                        Escribir i2+1

                        Leer v[(i)+(i2)]

                FinPara

        FinPara

FinFuncion

Funcion totalVino

        Escribir 'seleccione el tipo de vino que desea ingresar'

        Escribir '1)tipoA'

        Escribir '2)tipoB'

        Escribir '3)tipoC'

        Escribir '4)tipoE'

        Escribir 'ingrese el tipo de vino'

        Leer tv

FinFuncion

Funcion totalPorAnio

        Definir i,i2,aux Como Entero

        Dimension anio[anios]

        Para i<-0 Hasta anios Hacer

                Para i2<-0 Hasta tipoDeVino Hacer

                        aux <- v

                        anio[i] <- anio[i]+aux

                FinPara

                Escribir 'el total del año %i es: %i',i+1,anio[i]

        FinPara

FinFuncion

...

Descargar como (para miembros actualizados)  txt (3 Kb)   pdf (42.5 Kb)   docx (12.1 Kb)  
Leer 5 páginas más »
Disponible sólo en Clubensayos.com