ClubEnsayos.com - Ensayos de Calidad, Tareas y Monografias
Buscar

Evidencia I: Código que convierte de grados Fahrenheit a grados Centígrados y viceversa

Resúmenes : Evidencia I: Código que convierte de grados Fahrenheit a grados Centígrados y viceversa. Ensayos de Calidad, Tareas, Monografías - busque más de 2.721.000+ documentos.

Enviado por   •  7 de Marzo de 2018  •  Resúmenes  •  1.194 Palabras (5 Páginas)  •  11 Visitas

Página 1 de 5

Evidencia I: Código que convierte de grados Fahrenheit a grados Centígrados y viceversa.[1]

Código 

Explicación

Proceso CentigradosAFahrenheit_FahrenheitACentigrados

Nombre que se le da a la ejecución.

        Definir C,F Como Numerica

Define las variables C,F como tipo de dato Numérica

        Definir Opc Como Entero

Define la variable Opc como tipo Entero

        Escribir "Opcion 1 convierte Centigrados a Fahrenheit";

 El Comando Escribir muestra el texto que esta entre comillas en la pantalla al momento de la ejecución

Escribir "Opcion 2 convierte Fahrenheit a Centigrados";

        Leer Opc;

El Comando leer se utiliza para leer lo que el usuario podrá

        Si Opc=1 Entonces

El Comando Si-Entonces da la indicación de ejecutar una opción si la respuesta de la pregunta(tiene que ser lógica) es positiva entonces hará la acción por verdadero si no es así

                Escribir "Dame los grados centigrados"

hará lo que dice Sino.

                Leer C;

                F<-((9/5)*(C)) +32;

                Escribir "Los grados fahrenheit son:", F;

        Sino

Una vez que haya terminado la ejecución tendrá un Finsi lo que dará por terminada, la ejecución.

                si Opc=2 Entonces

Escribir "Dame grados fahrenheit";

                        Leer F;

                        C<-(5/9)*(F-32);

        Escribir "Los grados centigrados son",C;

                Sino

                        Escribir "Opcion erronea";

                FinSi

        FinSi

FinProceso

Este comando dará aviso de que se ha terminado la ejecución.

Evidencia II: código para calcular la equivalencia de dólares a pesos y viceversa.[2]

Código

Explicación

Proceso Peso_Dolar_Dolar_Peso    

El nombre que se le da al proceso

        definir ventaDolar Como Numerica

Se define la variable VentaDolar como Numerica

Definir compraDolar como numerica

Define la variable como compraDolar como numerica

        Definir resultado como numerica

Define la variable resultado como Numerica

        Definir Valor1 Como numerica

Define la variable Valor1 como numerica

        Salir="n"

Se le asigna “n” a la variable salir

    Mientras salir="n" o salir="N" Hacer

El comando Mientras se utiliza para que realice una ejecución mientras se desee poniendo

    Escribir "Elige una de las opciones:";

El mensaje colocado en el comando escribir será el que aparezca al momento de la ejecución.

 Escribir "opcion1 convierte de pesos a dolares";

El mensaje colocado en el comando escribir será el que aparezca al momento de la ejecución.

  Escribir "opcion2 convierte de dolares a pesos";

El mensaje colocado en el comando escribir será el que aparezca al momento de la ejecución.

                leer opc

El comando Leer sirve para que el usario  ponga lo que se le pide en cuestión y el programa lo lea

                  Si opc=1 Entonces

El comando si-Entonces da la indicación de si la respuesta el positiva o igual que la condición entonces ejecutara la acción correspondiente

          Escribir "escribe cifra en pesos"

Al momento de la ejecución se escribirá el mensaje que se encuentra entre comillas

                          Leer Valor1

El programa leerá el valor1 que será puesto por el usuario

          Escribir "escribe valor del dolar";

Se colocara el mensaje de comillas en la pantalla

                          Leer compradolar

El programa leerá nuevamente una variable colocada por el usuario

          Resultado<-(valor1/compradolar)

Se le asigna a Resultado, lo que dé como resultado al dividir las variables mencionadas.

  Escribir "El resultado es:", Resultado, "Dolares"

El mensaje entre comillas aparecerá en la ejecución, seguido del valor asignado en resultado y por ultimo otro mensaje.

                  Sino

El comando sino pertenece a la segunda parte de Si-Entonces la cual hará las acciones por negativo

  Escribir "escribe cifra en dolares"

El mensaje entre comillas aparecerá en el momento de la ejecución

                          Leer Valor1

El programa leerá el valor de la variable Valor1

  Escribir "escribe la venta del dolar"

El mensaje que está en comillas aparecerá en la ejecución

                          Leer ventadolar

Leerá el valor de la variable ventadolar

          Resultado<-(Valor1*ventadolar)

Resultado se le asigna el resultado de la operación descrita

Escribir "el resultado es: ", Resultado, "Pesos"

El programa escribirá el mensaje de entre comillas, después el valor de Resultado y enseguida otro mensaje

                  finsi

El comando Finsi da por terminado la ejecución Si-Entonces

  Escribir "¿Desea salir (s/n) o (S/N)?";

Volverá a mostrar un mensaje en forma de pregunta

                          Leer Salir

Leerá la respuesta y compara si es igual al valor asignado de Salir

                  Borrar Pantalla

Este comando al estar en momento de ejecución funcionara borrando todos los procedimientos hechos

          Fin Mientras

Este da por terminado el proceso Mientras

FinProceso

Indica que se ha acabado todo el proceso de ejecución

...

Descargar como (para miembros actualizados)  txt (5.4 Kb)   pdf (94.6 Kb)   docx (12.1 Kb)  
Leer 4 páginas más »
Disponible sólo en Clubensayos.com
Generador de citas

(2018, 03). Evidencia I: Código que convierte de grados Fahrenheit a grados Centígrados y viceversa. ClubEnsayos.com. Recuperado 03, 2018, de https://www.clubensayos.com/Ciencia/Evidencia-I-Código-que-convierte-de-grados-Fahrenheit/4307348.html

"Evidencia I: Código que convierte de grados Fahrenheit a grados Centígrados y viceversa" ClubEnsayos.com. 03 2018. 2018. 03 2018 <https://www.clubensayos.com/Ciencia/Evidencia-I-Código-que-convierte-de-grados-Fahrenheit/4307348.html>.

"Evidencia I: Código que convierte de grados Fahrenheit a grados Centígrados y viceversa." ClubEnsayos.com. ClubEnsayos.com, 03 2018. Web. 03 2018. <https://www.clubensayos.com/Ciencia/Evidencia-I-Código-que-convierte-de-grados-Fahrenheit/4307348.html>.

"Evidencia I: Código que convierte de grados Fahrenheit a grados Centígrados y viceversa." ClubEnsayos.com. 03, 2018. consultado el 03, 2018. https://www.clubensayos.com/Ciencia/Evidencia-I-Código-que-convierte-de-grados-Fahrenheit/4307348.html.