ClubEnsayos.com - Ensayos de Calidad, Tareas y Monografias
Buscar

Escribir un programa que pida al usuario que introduzca dos números reales y que imprima en la pantalla cuál es el mayor, y si son iguales que imprima el siguiente mensaje “estos números son iguales”.


Enviado por   •  26 de Abril de 2017  •  Ensayos  •  4.073 Palabras (17 Páginas)  •  188 Visitas

Página 1 de 17

Amilpa Olivera Joseph[pic 1]

Cibernética y computación II

Grupo:

Prof. Ing. Abril Daniela Solís Real

ESTRUCTURAS DE CONTROL EN PASCAL:

IF-THEN-ELSE

INDICE

EJERCICIO 1.        3

EJERCICIO 2.        5

EJERCICIO 3.        8

EJERCICIO 4.        12

EJERCICIO 5.        14

EJERCICIO 6.        17

EJERCICIO 7.        19

EJERCICIO 1.

  1. Escribir un programa que pida al usuario que introduzca dos números reales y que imprima en la pantalla cuál es el mayor, y si son iguales que imprima el siguiente mensaje “estos números son iguales”.

Algoritmo.

INICIO

1.-Pedir dos números reales al usuario (a y b)

2.-Hacer comparación:

     (a

3.-Mostrar el resultado de la comparación.

FIN

Diagrama de flujo.

[pic 2]

 

Pseudocódigo.

Algoritmo ejercicioA

        Escribir 'Inserta dos valores'

        Leer a

        Leer b

        Si a>b Entonces

                Escribir 'El numero mayor es:',a

        Sino

                Si a

                        Escribir 'El numero mayor es:',b

                Sino

                        Escribir 'Los dos numeros son iguales'

                FinSi

        FinSi

FinAlgoritmo

Código Fuente.

program numeroMayor;

uses crt;

var A,B:real;

begin

clrscr;

writeln ('Pon el 1er número');

readln (A);

writeln ('Pon el 2do número');

readln (B);

if (A>B)

then writeln ('el numero mayor es:',A:0:0);

if (A

then writeln ('el numero mayor es:',B:0:0);

if (A=B)

then writeln ('los numeros son iguales: /n',B:0:0,'=',A:0:0);

readln

end.

EJERCICIO 2.

  1. Escribir un programa que acepte 3 números reales y que imprima el resultado de la suma, el promedio, el producto e indique cuál es el número menor y cual el mayor.

Algoritmo.

INICIO

1.- Pedirle tres números reales al usuario (a, b y c)

2.- Sumar los tres números (a+b+c)

3.- Mostrar el resultado

4.-Sacar promedio de los tres números, ósea sumarlos y después dividirlo entre tres (a+b+c/3)

5.- Mostrar resultado

6.-Multiplicar los tres números (a*b*c)

7.- Mostrar resultado

8.- Hacer comparación de los tres números para saber cuál es el mayor

9.-Mostrar resultado

10.-Hacer comparación de los tres números para saber cuál es el mayor

11.-Mostrar resultado

FIN

Diagrama de flujo.

[pic 3]

Pseudocódigo.

Algoritmo ejercicioB

        Escribir 'Inserta tres valores'

        Leer a

        Leer b

        Leer c

        SUMA <- a+b+c

        Escribir 'La suma de los tres numeros es:',SUMA

        PRODUCTO <- a*b*c

        Escribir 'El producto de los tres numeros es:',PRODUCTO

        PROMEDIO <- a+b+c/3

        Escribir 'El promedio de los tres numeros es:',PROMEDIO

        Si a>b Y a>c Entonces

                Escribir 'El mayor es:',a

        Sino

                Si b>a Y b>c Entonces

                        Escribir 'El mayor es:',b

                Sino

                        Si c>a Y c>b Entonces

                                Escribir 'El mayor es:',c

                        Sino

                                Escribir 'Los numeros son iguales'

                        FinSi

                FinSi

        FinSi

        Si a

                Escribir 'El mayor es:',a

        Sino

                Si b

                        Escribir 'El mayor es:',b

                Sino

                        Si c

                                Escribir 'El mayor es:',c

                        Sino

                                Escribir 'Los numeros son iguales'

                        FinSi

                FinSi

        FinSi

FinAlgoritmo

Código Fuente.

program numeroMayor3;

uses crt;

var a,b,c,SUMA,PRODUCTO,PROMEDIO:real;

begin

clrscr;

writeln ('Inserta el primer valor');

...

Disponible sólo en Clubensayos.com