ClubEnsayos.com - Ensayos de Calidad, Tareas y Monografias
Buscar

Programacion pseint

Trabajos : Programacion pseint. Ensayos de Calidad, Tareas, Monografías - busque más de 2.741.000+ documentos.

Enviado por   •  14 de Septiembre de 2018  •  Trabajos  •  2.259 Palabras (10 Páginas)  •  3 Visitas

Página 1 de 10

[pic 1][pic 2][pic 3][pic 4]

|[pic 5]

Ejercicio 5

SubProceso impri<-imp (extra,din,p)

        Escribir ' pagaras: ',din,' por ',p,' horas',', mas ',extra,' hora(s) extra(s)';

FinSubProceso

SubProceso extra<-ex (p)

        extra<-trunc(p/5);

FinSubProceso

SubProceso imprimir (din,p)

        Escribir 'pagaras: ',din,' por ',p,' horas';

FinSubProceso

SubProceso din<-costo (p)

        din<-p*10;

FinSubProceso

Proceso internet

        Escribir 'dame las horas: ';

        Leer p;

        Si p<5 Entonces

                din<-costo(p);

                imprimir(din,p);

        Sino

                din<-costo(p);

                extra<-ex(p);

                impri<-imp(extra,din,p);

        FinSi

FinProceso

Diagrama[pic 6]

        

Ejercicio 8

SubProceso imprime (tpa,descu)

Escribir "el descuento sobre la compra es de: ",descu," y el monto total a pagar es de: ",tpa;

        

FinSubProceso

SubProceso tpa<-pago (p,descuento)

        tpa<-p-descuento;

FinSubProceso

SubProceso descuento<-des (p)

        descuento<-p*.35;

FinSubProceso

Proceso FAMERCIA

        Escribir "precio: ";

        Leer p;

        descuento<-des(p);

        tpa<-pago(p,descuento);

        imprime(tpa,descuento);

FinProceso

[pic 7]

Ejercicio 11

SubProceso imprime (mt)

Escribir "el total de dinero es de: ",mt;

FinSubProceso

SubProceso mt<-moneda (m1,m5,m10)

mt<-(m1*1)+(m5*5)+(m10*10);

FinSubProceso

Proceso DINERO

Escribir "monedas de 1: ";

Leer m1;

Escribir "monedas de 5: ";

Leer m5;

Escribir "monedas de 10: ";

Leer m10;

mt<-moneda(m1,m5,m10);

imprime(mt);

FinProceso

[pic 8]


Ejercicio 14

subProceso imp ( est )

Escribir "r= ",est;

Fin subProceso

SubProceso est<- bre (x )

est<-(3 * X) + (X/2 - (X*X));

        

FinSubProceso

Proceso funcionmatematica

Escribir "dame numero:";

Leer x;

si x>=0 && x<=20 Entonces

est<- bre (x);

imp( est );

FinSi

        

FinProceso

[pic 9]

Ejercicio 15

SubProceso imprimir (n,n1,n2)

Escribir 'x=',n,'',n1,'',n2;

        

FinSubProceso

Proceso variables

Escribir "dame un numero: ";

Leer n;

Escribir "dame un numero: ";

Leer n1;

Escribir "dame un numero: ";

Leer n2;

imprimir(n,n1,n2);

FinProceso[pic 10]

Ejercicio 42

SubProceso imprime (edniños)

Escribir "niño ",edadniños;

FinSubProceso

SubProceso noni (edadniños)

Escribir "no niño ",edadniños;

FinSubProceso

Proceso edades

Escribir "dame la edad de niños";

Leer edadniños;

Si edadniños<10 Entonces

imprime(edadniños);

SiNo

noni(edadniños);

FinSi

FinProceso

[pic 11]

        

Ejercicio 46

SubProceso impr (opdos)

Escribir "costo de la llamada: ",opdos;

FinSubProceso

SubProceso opdos<-caldos (dura1)

opdos<-(dura1-5)*1.1+(5*.9);

FinSubProceso

SubProceso imprime (llam)

Escribir "la llamada realizada costo: ",llam;

FinSubProceso

SubProceso llam<-calcosto(dura1)

llam<-dura1*.9;

FinSubProceso

Proceso llamada

Escribir "dame duracion marcada";

Leer dura1;

Si dura1<=5 Entonces

llam<-dura1*.9;

imprime(llam);

Sino

opdos<-caldos(dura1);

impr(opdos);

FinSi

FinProceso

[pic 12]

Ejercicio 47

SubProceso tpuno <- u ( m,uno )

        tpuno<-m-uno;

        Escribir "pagaras: ",tpuno;

Fin SubProceso

SubProceso uno <- un ( m )

        uno<-m*.1;

Fin SubProceso

SubProceso tpdos <- pag ( m,dedos )

        tpdos<-m-dedos;

        Escribir "pagaras: ",tpdos;

...

Descargar como (para miembros actualizados)  txt (8.5 Kb)   pdf (623.9 Kb)   docx (202.4 Kb)  
Leer 9 páginas más »
Disponible sólo en Clubensayos.com
Generador de citas

(2018, 09). Programacion pseint. ClubEnsayos.com. Recuperado 09, 2018, de https://www.clubensayos.com/Tecnología/Programacion-pseint/4485377.html

"Programacion pseint" ClubEnsayos.com. 09 2018. 2018. 09 2018 <https://www.clubensayos.com/Tecnología/Programacion-pseint/4485377.html>.

"Programacion pseint." ClubEnsayos.com. ClubEnsayos.com, 09 2018. Web. 09 2018. <https://www.clubensayos.com/Tecnología/Programacion-pseint/4485377.html>.

"Programacion pseint." ClubEnsayos.com. 09, 2018. consultado el 09, 2018. https://www.clubensayos.com/Tecnología/Programacion-pseint/4485377.html.