ClubEnsayos.com - Ensayos de Calidad, Tareas y Monografias
Buscar

Instituto IACC Análisis de Algoritmos Control 3

Trabajos : Instituto IACC Análisis de Algoritmos Control 3. Ensayos de Calidad, Tareas, Monografías - busque más de 2.726.000+ documentos.

Enviado por   •  15 de Abril de 2018  •  Trabajos  •  821 Palabras (4 Páginas)  •  68 Visitas

Página 1 de 4

Introducción a los algoritmos

Alfonso Alvarado

Análisis de Algoritmos

Instituto IACC

28 de Enero 2018


Desarrollo

  1. Skynet, una nueva y prometedora compañía fabricante de robots, lo ha contratado a Ud. para completar el diseño de sus nuevos modelos de robots de transporte de bodega. Estos robots tienen las siguientes funciones programadas:
  • avanzar(x): el robot avanza x metros.
  • girar(x): el robot gira 45 grados a la derecha a partir del lugar donde apuntan sus ojos.
  • tomar(): el robot toma y levanta el objeto que está frente a él.
  • dejar(): el robot deja en el suelo el objeto que tiene en las manos y lo suelta.

De acuerdo al conjunto básico de instrucciones, cree los diagramas de flujo y pseudocódigo para:

        

  1. girar_derecha(x): el robot gira x grados a la derecha.

Se ingresa el valor numérico de los grados en que el robot girará. También se pone una situación booleana en caso de que el valor sea muy bajo para realizar la operación con éxito.

Algoritmo sin_titulo

        Escribir 'Ingresar en cuantos grados el robot gira a la derecha'

        Leer girdere

        Si girdere>10 Entonces

                Escribir 'el robot gira a la derecha en ',girdere,' grados'

        SiNo

                Escribir 'valor muy bajo para efectuar la operación'

        FinSi

FinAlgoritmo

[pic 1]

[pic 2]

[pic 3]

  1. retroceder(x): el robot da media vuelta y se mueve x/2metros.

Algoritmo sin_titulo

        Escribir 'numero de metros a retroceder'

        Leer metrosretro

        retrocede <-metrosretro*0.5

        Escribir 'el robot gira 180 grados y retroce ' retrocede ' metros.' ;

FinAlgoritmo

[pic 4]

Se ingresa el valor numérico que se usara para calcular los metros que el robot retrocederá.

[pic 5]

[pic 6]

  1. Sean los números N1, N2 y N3. Se desea saber si uno de ellos equivale a la resta de los otros dos, es decir si: N1 = N2 - N3, N2= N1 - N3 o N3 = N1 - N2. Puede emplear la palabra “Falso” en caso que no se pueda demostrar la resta.
  • Escriba el pseudocódigo de un algoritmo para el caso planteado. En caso que Ud. lo necesite, puede apoyarse en una narrativa del algoritmo o un diagrama de flujo.
  • ¿Cómo se escribiría el algoritmo de la pregunta anterior en PHP? Haga solamente el bloque de if/else para el cálculo de la resta de los números.

Algoritmo

        Escribir 'primer número'

        Leer N1

        Escribir 'segundo numero'

        Leer N2

        Escribir 'tercer numero'

        Leer N3

        si N1=N2-N3 Entonces

                Imprimir "el número ", N1 "es la resta de ", N2 " y ", N3;

        SiNo

                Imprimir "el número ", N1 "no es la resta de ", N2 " y ", N3;

        FinSi

        si N2=N1-N3 Entonces

                Imprimir "el número ", N2 "es la resta de ", N1 " y ", N3;

        SiNo

                Imprimir "el número ", N2 "es la resta de ", N1 " y ", N3;

...

Descargar como (para miembros actualizados)  txt (3.4 Kb)   pdf (321.4 Kb)   docx (98.7 Kb)  
Leer 3 páginas más »
Disponible sólo en Clubensayos.com
Generador de citas

(2018, 04). Instituto IACC Análisis de Algoritmos Control 3. ClubEnsayos.com. Recuperado 04, 2018, de https://www.clubensayos.com/Tecnología/Instituto-IACC-Análisis-de-Algoritmos-Control-3/4339484.html

"Instituto IACC Análisis de Algoritmos Control 3" ClubEnsayos.com. 04 2018. 2018. 04 2018 <https://www.clubensayos.com/Tecnología/Instituto-IACC-Análisis-de-Algoritmos-Control-3/4339484.html>.

"Instituto IACC Análisis de Algoritmos Control 3." ClubEnsayos.com. ClubEnsayos.com, 04 2018. Web. 04 2018. <https://www.clubensayos.com/Tecnología/Instituto-IACC-Análisis-de-Algoritmos-Control-3/4339484.html>.

"Instituto IACC Análisis de Algoritmos Control 3." ClubEnsayos.com. 04, 2018. consultado el 04, 2018. https://www.clubensayos.com/Tecnología/Instituto-IACC-Análisis-de-Algoritmos-Control-3/4339484.html.